This is the common anti-pattern:
/// <summary>If you multiply that by every public method and or test it can make the class files look a bit jumbled.
/// Tests if an order can be prepared for printing.
/// </summary>
[Test]
public void PrepareOrder()
{
...
}
So why not refactor by renaming the method and lose the comment?
[Test]or even
public void OrderCanBePreparedForPrinting()
{
...
}
[Test]I find this far easier on the eye.
public void Order_Can_Be_Prepared_For_Printing()
{
...
}
No comments:
Post a Comment